Home Forums SharewareOnSale Deals Discussion SoftOrbits Photo Editor Pro 7 / Jul 10 2021

Viewing 15 posts - 16 through 30 (of 30 total)
  • Author
    Posts
  • #18180152 Reply | Quote
    jake
    Guest

    Why doesn’t anyone, be it the Developer, or Ashraf, respond to our concerns?

    #18180769 Reply | Quote
    Pee
    Guest

    I couldn’t register Photo Editor with giveaway’s serial. It’s showing “Error connecting activation server” every time I set it up.

    #18184366 Reply | Quote
    Tony Class
    Guest

    [ @Pee]

    To solve the “Error connecting activation server” problem I had to lose a few hours.
    This is a personal problem and none of our service staff will answer us!
    For the program to start, you need to clear the registry / manually / all remnants
    of previous versions of SoftOrbits Photo Editor Pro and turn off your antivirus program on
    the computer!
    Your internet connection should be good too!

    #18190520 Reply | Quote
    Harlan
    Guest

    I had V5 installed, but uninstalled it before trying to install this version. It is reporting itself as V5 Trial, and it does not accept the license key (which I assume is for V7). I am on Win10 Pro x64, patched up-to-date.I see some people are having success, but I’m not.

    #18195548 Reply | Quote
    Allan
    Guest

    Like others, after installation I got the error message “The application was unable to start correctly (0xc000007b). Click OK to close the application.” This occurred on two different Windows 10 computers. I informed Soft Orbits of this when I uninstalled, but have not heard anything from them. This might be a useful program, but I guess I’ll never know.

    #18196221 Reply | Quote
    jake
    Guest

    SoftOrbits, could you be kind enough to address our issues with your giveaway.

    Thank you, in advance.

    #18204739 Reply | Quote
    jake
    Guest

    To me it appears pretty obvious that the problem I have encountered with the failed attempts to launch SoftOrbits Photo Editor 7 is the consequence of the sloppy programing.

    #18204840 Reply | Quote
    jake
    Guest

    Ok, I have just decided to remove the offending dll from the installed SoftOrbits Photo Editor, and guess what: the program now launches and works without a hitch.

    Thank heavens!

    #18207075 Reply | Quote
    Allan
    Guest

    [ @jake] I deleted VCOMP140.DLL – is that what you did? After deleting it I got an error message telling me that it was missing. When I copied the same file from elsewhere on my computer (there were lots of them) I got the same 0xc000007b error as before.

    #18207967 Reply | Quote
    Ryszard
    Guest

    Not able to register with given license Key,EDT7-PRO-LRKNE-LPHPD-HTKPT
    please help

    #18208090 Reply | Quote
    jake
    Guest

    [ @Allan]

    Dear Alan,
    That’s the dll I was referring to, in my original post. Maybe I just lucked out.
    My OS is 20h2 32 bits.

    I am so sorry that it didn’t work out for you.

    BTW, to get back your deleted dll file, remove the program completely, and reinstall it.

    #18208512 Reply | Quote
    Takács Gábor
    Guest

    Deleting VCOMP140.DLL solved the problem. Thanks for the tip.

    #18210043 Reply | Quote
    Kevin
    Guest

    Error: Activation keys doesn not match

    #18210439 Reply | Quote
    Dick
    Guest

    Looks like it would be useful, but it requires a device and all I have is a laptop. “This giveaway is only for devices.”

    #18210497 Reply | Quote
    Dick
    Guest

    Rewind: restarted the process and it worked fine.

Viewing 15 posts - 16 through 30 (of 30 total)
Reply To: Reply #18177608 in SoftOrbits Photo Editor Pro 7 / Jul 10 2021