Home Forums SharewareOnSale Deals Discussion Sketch Drawer Pro / Aug 24 2017

Viewing 15 posts - 16 through 30 (of 57 total)
  • Author
  • #8752458 Reply | Quote

    Same issue
    Won’t register

    #8752529 Reply | Quote

    I get a different error ‘You have entered an incorrect registration code’ – but I see it is correct…

    #8752820 Reply | Quote
    John Oakley

    Key worked fine. Just tried it out — obviously just started scratching the surface, but it works as advertised and there are plenty of variables to try out! From a user experience viewpoint, it would be good if a) each toolbox slider had a numbered box, and b) there was a “save” facility so a useful combination of variables could be saved for future use. I liked it — simple and straightforward. Thanks! Is there a manual or anything?

    #8753059 Reply | Quote
    joe s

    Attempted to register, but like many others it would not accept the key. I thought it was something I had done wrong, like not uninstalling V4.0.4.0 before installing the new one. So I uninstalled both and tried again, same issue. So now I had hosed my previous version as well. Fortunately I have learned to do a restore point before installing anything from any free SW site and was able to revert everything so the older version is back. I also have other SW for doing the same thing this one does. So I am not particularly worried about not having this one, altho it sounds as if it has capabilities the older V does not. But I will live. Too bad, the older version is rather cool and I was looking forward to an update. It is not something I would use often, just a fun toy. If asked I would recommend a pass on this opportunity. Also, the CAPTCHA really does seem needlessly complex. In some cases such things have discouraged me from posting at all. They won’t die if they don’t have my opinion.

    #8753062 Reply | Quote
    Frank Choux

    SAME PROBLEM ! I deleted my older version thinking that was the problem – grrr — Please get us a NEW KEY !

    #8753427 Reply | Quote

    Most people have problems with software that were giveaways from SoftOrbits. Often, already registered versions suddenly become test versions again and one is asked to buy the software.

    Often, the sent license key is suddenly invalid and you have to buy a new one.

    #8753624 Reply | Quote
    good bye

    thanks for killing the working version

    no more keys from here!!!

    good bye :(((

    #8753681 Reply | Quote

    With so many reporting that the registration key doesn’t work (same with me!), why doesn’t the author reply? We need a new (or working) activation key!

    #8754254 Reply | Quote

    Same problem the “SharewareOnSale exclusive license key” does NOT work.

    #8754404 Reply | Quote

    plzzzzzz help
    having this issue


    #8754412 Reply | Quote
    #8754585 Reply | Quote
    Eugene, SoftOrbits

    We carefuly checked the “activation error license key already used” issue and did not found any problems.
    We have than 2400+ successfull activations. Please uninstall the older version of the program, temporary disable your antivirus and firewall and try once again. If there is still any problems please contact support@softorbits.com

    #8754703 Reply | Quote

    [@Eugene, SoftOrbits]

    From what I can see is that SharewareOnSale is giving out the same activation key to multiple people (I tested this across multiple PCs).

    So is there only 1 activation key for all the free copies today, or is SharewareOnSale screwing up the key distribution?

    #8754842 Reply | Quote

    [@Fallen] We aren’t screwing anything up.

    : If you are downloading the software from anywhere except our website, then it will NOT register properly. Make sure you are installing it from us.

    #8754921 Reply | Quote



    I know that you are not at the origin of this problem
    I think that Softorbits are not really serious. I’ve tried with firewall and antivirus disabled and the result is still the same: activation error key already used. 2400 activations they say..ok but where ? If activations are restricted to some countries it may be a reason of this problem. Not solved for me at this time.

    I got other software from this editor and it is necessary to allow access when activating and after done to disable any access to internet, and then the activation stay enabled. I discovered this way to do with Softorbits software one time before with activation of “Background remover” was lost without any reason.


Viewing 15 posts - 16 through 30 (of 57 total)
Reply To: Sketch Drawer Pro / Aug 24 2017