Home Forums SharewareOnSale Deals Discussion CyberLink PhotoDirector 9 / May 25 2019

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13798945 Reply | Quote

    Ashraf
    Keymaster

    Have something to say about CyberLink PhotoDirector 9? Say it here!

    Have suggestions, comments, or need help? Post it here! If you know of better software than CyberLink PhotoDirector 9, post it here! If you know of issues with CyberLink PhotoDirector 9, post it here! Share your knowledge with all of us. :-)

    #13802716 Reply | Quote

    Luke

    This concerns the registration process of Cyberlink PhotoDirector 9. I am unable to register the product using the provided key. The error message says that connection with server is impossible, and to check my internet connection.

    I have full internet connection and no particular firewall setting to block this connection. I tried to uninstall everything, download again and reinstall, but with the same error message. I am left with an unregistered version…

    Please help!

    Thank you

    #13808930 Reply | Quote

    Paul

    Cyberlink PhotoDirector 9 (64 bit) refuses to install because, after inputting the key and pressing activate; the Windows 10 Usaer Account control dialog box comes up and asks if I wish to run, the when I say yes, and start the installation, mmediately a PhotoDirector dialog box come up saying “The activation did not complete successfully because you chose not to allow it in the Windows Account Control dialog. Try it again etc.”
    This is not the first program I’ve installed today so the Windows UAC dialog is working correctly, so it’s a bug in the PhotoDirector. ( Stupidly I’ve just unistalled PhotoDirector 7 and 8. )
    So what now?

    #13809425 Reply | Quote

    Paul

    [@Paul]
    OK, just for fun I reinstalled version 8 from and archived exe, activated using the old code and it worked! So I started all over with 9, but instead of installing directly from the ‘hub’ link, I asked for the ‘backup’ to be installed, and executed from there. After uninstalling the 9 already installed it installed correctly and accepted the Activation key, and is now busy trying to update a PhotoDirector 5 project file it has found. So, fingers crossed / knock on wood,PD 9 seems to be functioning this time arond.
    Oof!
    Sorry for the disturbance! Have a nice day!

    #13811967 Reply | Quote

    Dx

    As soon as I encountered that “cannot reach activation server” message, I uninstalled the program. There’s no point in jumping through hoops to get older software to register properly. What a waste of time. Thanks a lot, SharewareOnSale.

    #13832503 Reply | Quote

    黎永昌

    my work is computer engineer

    #13832508 Reply | Quote

    黎永昌

    computer engineer

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: CyberLink PhotoDirector 9 / May 25 2019